Back to overview
Maintenance
Hotfix production
May 09 at 04:15pm CEST
–
May 09 at 05:00pm CEST
Affected services
staffbeat.app
Resolved
May 09 at 04:15pm CEST
hotfix
Affected services
staffbeat.app
Resolved
May 09 at 04:15pm CEST
hotfix
Affected services
staffbeat.app