Back to overview
Maintenance
1.5.0
Apr 18 at 05:30pm CEST
–
Apr 18 at 08:30pm CEST
Affected services
staffbeat.app
Resolved
Apr 18 at 05:30pm CEST
Production release
Affected services
staffbeat.app
Resolved
Apr 18 at 05:30pm CEST
Production release
Affected services
staffbeat.app